Installing nVidia Drivers on LMDE

The Why

I’m running Linux Mint Debian Edition (LMDE), and I needed to install the nvidia drivers in order to develop WebGL applications. Without the nvidia drivers, the display was a little laggy, but fast enough. Not being able to run WebGL, however, was kind of a show stopper.

So I did a bunch of research. There’s a lot of information out there, and only some of it is contradictory, but it’s all confusing. Everything seemed tailored for either Linux Mint or Debian, not LMDE. And there are also a lot of warnings about systems that don’t boot after rejecting the new drivers. All of this lead to a few hours of hand-wringing before I took the plunge.

Turns out it’s really easy.

The How

This is my setup:

I was running the nouveau driver which was automatically installed with the OS.

Working mostly from this Debian wiki article, I first installed and ran nvidia-detect

The recommendation seemed strange, since the Linux Mint forums liked to install nvidia-glx, and that Debian wiki wanted to install nvidia-kernel-dkms, but I decided to trust the script.

Running that installed a bunch of packages, threw up a couple of warnings about changing the Xorg config, and built a new kernel with the drivers installed.

After that, you need to config your system to use the new drivers. I followed the Debian wiki again for this part.

For the contents of that file, I put

The What

I hoped I was all done, so I crossed my fingers and rebooted. And it worked!

The What What?

And now Steam is broken. Running your own linux system is a full-time job.

4 Comments

  1. Thank you. Thank you. Thank you.

    Just used your guidelines to install legacy driver for my NVIDIA G84 [GeForce 8600 GT] on my LMDE-2 Mate.

    Worked great.

    I don’t use Steam so not a problem there.

    FYI: I’ve got an older Intel Q8300 with 8Gb ram, ASRock P43DE3L Mobo, Samsung 850 EVO 120Gb SSD (Boot & /), WD 2T (/tmp & /home) & of course, nVidia 8600

    Again, thanks bunches

    Reply

  2. Worked for me
    OS LMDE 2 64 bit
    Card GeForce 7300 SE/7200 GS
    Driver nvidia-legacy-304xx-driver
    Many thanks

    Reply

  3. DOES NOT work for me.
    OS LMDE2 64 bit
    GeForce GT 630
    Driver nvidia-legacy-304xx-driver.

    Xorg failed to start until I remove driver line from config.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *